help with particles


(nemesis) #1

I’m making a comet and it’s parented to a nurbs curve so it can move around. well whenever I make this curve longer, the tail of the comet gets longer and the particles are more seperated. How can I fix this?


(hannibar) #2

You can make the tail less long by making the life of the particles shorter. In the animation buttons, in the particle window, you’ll see a button called life, play with that.
If you just want to fill up the spaces between the particles, you can just raise the number of particles.

hope that helps.

-hans-


(haunt_house) #3

how do you make it longer? do you simply scale it?

HH


(nemesis) #4

if you’re talking about the curve, I just go in edit mode and move the vertexes to make it longer. If you’re talking about the particles, it just does it by itself.


(haunt_house) #5

sorry. haven´t been able to rebuild the problem. The tail keeps one size, no matter how big the nurbs curve is.

What I did was this:

I made a nurbs curve (cyclic). I placed an Empty where the sun should be. I parented a mesh to the curve, made it curvefollow cleared the origin, gave it a particle effect with ‘norm’. I gave the mesh a ‘trackto’ constraint to point on the Sun-empty. When I now alter the curve in edit-mode, the tail keeps its length.

strange

HH


(nemesis) #6

If you give me your email I could send it and see if you can find the problem. About the empty, what’s the point of having it? Like what does it do?


(hannibar) #7

nemesis : have you already tried what I told you. I really think this might resolve your problem.


(Dittohead) #8

did you hit ecalcall in particles screen


(nemesis) #9

hannibar: yes I did a bit, but I would do that last since I don’t know how long my curve will be yet.


(theeth) #10

If you increase the OB setting of the particles, they should stick a bit more to the emitter as a by product of the motion.

Martin


(haunt_house) #11

I used the empty to simulate a sun. A comets tail always points away from the sun. So I let the emitter mesh point away from the sun with a constraint. Then, the normals will give it the right direction. I haven´t tried how to do it with a rotating comet yet. One day I will find out, how this texture-controlled particle movement works.

If the curve is longer, the comet will go faster. So he will be farther (?) away when the particles cease to be. So the tail is not only longer, but also thinner. One way to solve this problem is to increase the pathlen value in the anim buttons.

HH