Help with Rigid Body?

Heyyyy… I’m trying to get my object in my game to go down a slope but it keeps rolling. I’m trying to get it to slide without rolling if that is possible with GE??

I parented my model to an empty and am using the empty for controls. I did this so the x, y, and z axis’ on the model are fixed in place if that’s the right approach? If anyone could say how to do this (hopefully with no scripting involved :smiley: ) that would be awesome :slight_smile:

Thanks, and sorry for asking so many questions :stuck_out_tongue:

Man I had the same problem with my game. Instead of using an empty, use a box. Parent the model to a box and have it set as the “Dynamic” actor. After that, select “Bounds” and the box setting. Oh, and just in case if you experience any jitterness, set the damping to say .999. Let me know if you need an example.

use this latest build of blender. it has working rigid body with bullet physics…

Shn275, Thanks :smiley: but what dampening?

STELLA, I’ve been wanting to try that but there’s no mac release :frowning:

Sorry man, I meant “Damping”. Check out the attachment.


Turn riged body off too stop the rolling. :slight_smile:

Nah I want to use rigid body so the object follows the slopes rather than staying flat. Shn275, actually my bad :stuck_out_tongue: You did say “damping” I said “dampening” :o

:frowning: K I just tried that… It doesn’t work… thanks anyways

There is no way to let the object rotate and not rotate simultaneosly.

However, it sound like you want the FH rot feature. Turn on FH Rot [game buttons for your object], set the FH Force and FH Dist [under the dyn buttons] on the ground material. [also have rigid body off]

It’s more visible with FH FLoat and FH Norm [same two places respectively] set

of course, I haven’t tried this on bullet physics, but it worked just fine with SUMO [unless your bounds weren’t sphere]