Help with Script window

Hi. I read about updating the menu in the Script window on a website about the Fiber generator. I followed the instructions and place the necessary code at the beginning of each of my scripts:

#!BPY

""" Registration info for Blender menus: <- these words are ignored
Name: 'Fiber Generator v2.03'
Blender: 233
Group: 'Misc'
Tip: 'Fiber Generator.'
"""

This is the one I used in the FiberGUI.py. I have all of the scripts in my Blender directory. When, in Blender, I click Update Menus, nothing happens. Am I doing something wrong, or does this feature in Blender not work? Please help. Thanks.

-Laurifer

Hi

It is not necessary to make any modifications to the scripts if you load them the standard way via the text window. As I say in the ‘Installation Information Page’:

“It is possible to run Fiber 2.03 from the script window (as opposed to the standard method of running it from a text window) by making a couple of minor modifications to the FiberGui.py file.”

If you are not comfortable editing Python scripts, that is probably the better way to run the script(s).

If that’s not an issue and you wish to make the script easier to use, as is the case with more recently created scripts, or scripts that have been updated to be used in the Script Window, then you can make the modifications. Fiber is a little different in that it relies on more than a single Python script; which makes it a little more challenging setting it up to work with the new system of loading Python scripts.

So if that disclaimer doesn’t dissuade you, then proceed:

You only need to copy that header to the FiberGui.py file (version 2.03).

Then ensure that it and the remainder of the Fiber support scripts are copied into your scripts directory. For WinXP, this is:

C:\Documents and Settings%User_Name%\Application Data\Blender Foundation\Blender.blender\scripts

*Note: The location of your scripts directory will depend on your OS and the installation options you selected when you installed Blender.

This really only saves a small amount of effort of having to manually load the Fiber script files. If you intend to use the ‘Use Wind’ function, you will need to load the FiberAnim.py script via the text window method, since you need to create an Object script link. In that case, using the Script Window method is not too useful, and it is best to load all of the Fiber scripts via the text window.

As soon as Ripsting finishes his 2.5 release all of this will be moot anyway, but only Ripsting knows when that will be :wink:

Hope that helps.

Oh. Duh! I thought these files were supposed to go in C:\Program Files\Blender Foundation\Blender.

:expressionless:

-Laurifer

Working on it! New features take time to think out, experiment with, and impliment…

I’ll make sure to add the meta data to the top of my scripts from now on too.

Working on it! New features take time to think out, experiment with, and impliment…

I’ll make sure to add the meta data to the top of my scripts from now on too.[/quote]

Take your time. I would rather see it take longer to come out then to see it come out with bugs and not up to you standars.

I look forward to the next release!

-Laurifer

I’m also looking forward to the next release, but as they say “It’ll be ready when it’s ready”. So no rush :smiley:

Also, I was wondering if anyone confirmed some possible bugs or knew what I might be doing wrong to cause what I observed using the Fiber script? :

http://www.telusplanet.net/public/kugyelka/blender/tutorials/fiber/misc.html

Also, I was wondering if there was some other method that would allow use of face select without disabling the check for vertex colors as described in Point #3 here:

http://www.elysiun.com/forum/viewtopic.php?p=258375#258375

I find that using face select gives me more control over the application of vertex colors. Is there some other way to prevent inadvertant vertex color application to faces you didn’t intend to apply paint to? (Just curious. I’m happy with the ‘hack’, but wondering about alternatives).

Thanks for any help.

Hadn’t seen these bugs before. For the wind, it probably is just a matter of flipped signs. Honestly, I didn’t test it much- I basically took the code out of my old hair script. I’ve put some comments in my code where the major operations take place, so it shouldn’t be hard to find where I do the math. I’m not on my home computer right now so I can’t view your DivX files or make changes to my code at the moment.

As for the vertex paint problem… It’s probably being caused by Green=0. This would imply a zero-length fiber strand. I do some distance finding between contiguous vertices which might break if they’re overlapping. It might just take putting “+ 0.001” somewhere in the code to avoid the division by zero error and therefore make a temporary fix.

I just did a quick test and when I set the vertex color to R=0.010, G=0.000, and Blue = 0.500; there was no crash. The fibers came out to be very short triple-wide fibers. (Unless Blender is storing to a greater precision than what is observable in the RGB slider settings or some rounding-off is occurring).

Setting Red to 0, with a small Green value also didn’t cause a crash. Only when Red and Green were both set to 0, and Blue was at a non-zero value did a crash result.

Anyways, since I’ve been more carefull when I apply vertex colors I’ve experienced alot fewer crashes when using the Fiber script.