Help with shadows for a N00b

I have been working on the current scene below, and was told in the Works In Progress thread to have the glass cast a shadow onto the plane. However, despite how much I play with the settings I can’t seem to get it to work. Any ideas? :frowning:

The two lamps above the glass were there previously. One is a sun lamp creating sky, and the other is a hemi providing basic light to the scene. I am trying to use the spot to create shadows…


Make sure that the sun has the shadow button enabled,
If you want transparent shadows on the plane you need to enable receive transparent shadow in teh plane properties;)

With so little infomation (why are you so terrified to attach your blend file to your post) these are just guesses.

  • In the floor material have you set it to accept shadows
  • For the spot lamp have you set it to cast shadows
  • Increase the distance value for the spot lamp. The light strength may be so weak when it reaches the objects any shadows may be wiped out by the other lights in the scene. You can set the lamp to just cast shadows, not to light the scene.

I have tried those, I would upload the .blend, but it is too big… Any way to compress it?

Edit: Does the fact that the object is meant to be transparent have any affect on how to do a shadow?

Post you blend here It doesn’t have to be the whole blend. All it needs to do is to be able to show the problem.
Looks like you have a general shadow problem as I can’t see the dice casting any shadows as well as the glass.

hey, I’ve looked again to your picture and I’ve seen that the sun is turned to up, then it never will show the shadows in the ground, select it and then press alt+r to reset his rotation

Never noticed that!! Will try, thanks…

Edit: tried that, didn’t change anything, but am still playing with the settings…

On the other hand, I posted the .blend file here as requested…

This is probably a very simple problem that someone smarter than me can solve easily… Sorry!

For the spot lamp turn on Diffuse, change its colour from black to white, increase its distance value to say 50 and increase the samples value to reduce the graininess of the shadow. Buffer shadows will give a stronger shadow but you will have to adjust the shadow settings

You would think I would have stumbled upon that, but I obviously didn’t… Thanks for everyone’s help. :slight_smile: