Help with strange looking wireframe in object mode



I delete 2 connected faces and make one from each of them (1st pic blue circled), but when I switch to object mode, the old wireframe still appear and I don’t know how to get rid of them.

submit the blendfile for further review.

press N, and check the Clipping values. that should be the reason, but im not 100% sure.

as for the black lines in object mode, it could be anything.
try Alt + H in edit mode to check if they are hidden.

Your object looks very large so you may have changed the viewport start/end clip distances. Try and keep within the default grid size and clip settings.