Help with texture and lighting

I’m working on something in game mode where I have a scene like this

but, when I press play I get an invisible goat and no lighting. All the solutions I’ve seen are either wrong or very roundabout and unclear. Can anybody give me any clear or direct advice?

So you do not see anything? For the texture, make sure that the normals are facing the right way, that you are in GLSL shading mode, and that the Transparency in the Materials tab is not 0.0, or the Alpha in the Object Color part (object settings) is also not 0.0, or the Alpha in the Textures panel, under Color, is also not 0.0

I don’t know about the lighting, however. Either change from Multitexture to GLSL, oor check you are in Textured mode… You could post a screenshot of the game running (even if there’s nothing in it)

I think these are all the settings and it still doesn’t show up


Hmm, not sure what the problem is, but you could try re-unwrapping your texture, reloading the texture, ensuring your camera
clipping is large enough, and getting rid of obstructing camera foreground material if there is anything there.

I’m also curious as to how your texture is “going outside the bounds of the plane.” I think if you look at the picture you sent,
the hand of the goat is extending beyond the surface of the plane.

Are you able to provide a blend file?

Oh the arms are separate planes in front of and behind the main body plane. Here’s the updated blend file


wolf.blend (504 KB)

Oh, have you solved your problem? I took a look at the file, and it seems all your textures are showing up except for the goat. But you should reload your goat texture and try packing your file for it to show up (File -> External Data -> Automatically Pack Into .blend). After that could you resend the file?

I still haven’t fixed it. I tried packing them and it still didn’t show up for some reason. Maybe should try a video tutorial or something

Select the plane (the goat body), go to texture, browse down till ‘influence’ set Alpha to 0.

It made the texture disappear

Disabling it, I got this. Wheres the goat?

Your texture not packed properly.

I think hes saying the goat texture was not packed in the blend file you provided. Not that packing the texture should fix your file. Pack the goat texture and reupload the file so they can help

Ok I went back and tried to pack everything correctly and disabled alpha


wolf_2.blend (676 KB)

Try this: wolf_2 (2).blend (784 KB)

When working with alpha textures such as your case, make sure you turn “alpha” on for textures (value all the way to 1 depending on what you want), and turn material transparency all the way off. And as superflip and mziskandar suggest, make sure you pack your textures properly. Hope this is what you want.

EDIT: Check this file again if you have checked the older version I sent.

indeed to fix it just select the plane, material tab, you set transparent to 0, then head over to texture tab and set alpha to 1.0 and select it. jusl like mirror said.