Help with this smoke file please

Hi All,
I watched a tutorial and created smoke inside a cylinder. Funny thing is I was able to add a color to the smoke before Blender crashed. Now I cannot get back there again? Here is the Blend file to see the smoke. I would like to have my emitter green as well as the smoke be green too.

If you look at this pic (before crash) I did get a longer lasting smoke via viewing render. Now I am getting a subtle smoke ring at the bottom with no volume / dissipation as smoke would do…when checking via render view. Thanks in advance for some insight, direction.

http://www.pasteall.org/blend/30239


Attachments


Here are a couple of suggestions that might get you there:

  • turn off rendering for the particles (set render to ‘None’)
  • set density of the domain material to 0 and crank up density scale (~3 - 5)

KWD,
Thanks for that, but I do not know where to find those settings? I looked under a the three different settings for the two objects, domain and emitter where there are another 25 or so areas to look. Maybe a screen grab and a hi lite?
Thanks

So I found the “- set density of the domain material to 0 and crank up density scale (~3 - 5)”

I did not find the Particle render OFF
“- turn off rendering for the particles (set render to ‘None’)”

I did find the Smoke color adjuster. I am still not seeing it under a render view. I see my volume under material as in pic. I do not see it in Render view?
Here is the updated blend file and some grabs:

http://www.pasteall.org/blend/30253



To turn off particle render, go into the particle settings tab and under the render panel set it to None (by default it is set to Halo).

Is that what it will take to see a thicker flow distribution? I guess I will go find out. I am almost at that part of my animation where I need it to be ‘spot-on’ for the final out. Thanks again
Refer to the pic I do have it on Volume not Halo SEE pic with Red writing on it. Where is the NONE? I see Surface, Wire, Volume, Halo…

As I forgot to mention it, what you see isn’t smoke, this is actually the particles being rendered as halos. Here’s a screen grab for particle render (should have done this before… ;)).


And apparently, viewport rendering of smoke/volume doesn’t work anymore. I tried and it did work with previous versions, will need to check if whether this is a bug or it was deactivated.

KWD thank you for the screen grabs, those are always worth a 1000 words. I still do not see the NONE selection. Furthermore I see you are in fact on HALO, when you told me to not be. SO I am a bit confused… I will have my emitter setting match as your grabs are in 2.71 and see if that will get me there. IF NOT, I will follow up here. Thanks again

Sorry for the confusion, I took that screen grab out of a new blendfile to show you where the settings are; you should have it on ‘none’. Also, you should notice that on the screenshot, the particles are on the Smoke Domain, and not on the emitter as they should be…

One can be - use Space - Quick Smoke and adjust colors. Works almost out of the box.
If you set smoke like you have done there is not one important ingredient.

Domain contains something in it where you want smoke cloud to be. This something is “Voxel Data”. It can be rendered if there is light and it’s density is greater than 0. Just a colored shape, nothing interesting. If Density is set to 0 there will be nothing rendered.
Next you have Particle system which emits particles and you can shape them as you like. These you suppose will be smoke. Ha…
Blender cares nothing about and renders them as default Hallos. Domain and Voxel Data does not care Hallos either - you have something but this is not the smoke you would like.

You have not told particles to make trouble in Domain’s Voxel Data stills yet - you have to use Point Density texture to do this.
Particles itself need not be rendered not in a form of Objects not Hallos. They will create dense points in the Domain’s Voxel Data.

Here’s file back http://www.pasteall.org/blend/30337

@KWD- Hey man you STILL have not told me where NONE is located! LOL… haha 3rd time here.

@Eppo, You are very knowledgeable with Blender and many times your answers reflect that. (Where you are stating something I am trying to understand) Screen grabs are always appreciated. I will check your Blend file. Thank you for that. I am thinking for your opening sentence:
“One can be-” - ???
Use Spacebar - Menu>Quick smoke>adjust colors- This works better then the direction I was going and KWD has been helping with…

What I find frustrating with Blender; as I have mentioned before. There are many ways to achieve a blend file. All will work, not always in different versions…But sometimes, often many more then fewer, there is an easier way to ‘skin the cat’ then some tutorial I may have stumbled across. That is maybe something I should bring up on each question I post. Is there a better way to go about this then the direction I am going in?
Always appreciate your coaching and direction Eppo. Instead of beating a ‘dead horse’ you have me just use an ‘outta the box’ fix to start with.
IGE: Lights in the doorways. “Volume Lighting” Now Smoke- ‘outta the box’

Peace
NC

Eppo,
I am getting lost a bit. I was checking the file I tried to change the color of the smoke, under emitter and also domain.

I also have an intermittent (preview) going on also?
Where I can see the animation (not rendered only material) and then I cannot. I switched from cycles to B render and that also had an affect of the effect.

I DO want a transparent background and domain, so I that I can composite it in my scene. The smoke in (F12 preview) is to thick (not transparent, it is very dense)

I find myself clicking and adjusting with no idea of direction… Your file DID show an animation when I downloaded. After a few adjustments I lost the animation? Here is AFTER I got done messing with it…http://www.pasteall.org/blend/30347

  1. Which render engine should I use? In Cycles my viewport does not show the animation in any mode. Be it rendered, material. or texture?
    As a matter of fact it shows only the Domain as a cylinder object when rendered. B Render shows nothing not even an object when in Render object view. IN texture or material B Render only shows a wire view for the both with still no animation?


  2. Where is the smoke color adjusted? IGE Under Emitter object and then >Smoke?


  1. To make the smoke thinner or thicker ( to see thru or not) where is that adjustment? Is that done via emitter object or is that the domain or does the light angle play a part in it?

Thanks for help on this appreciate it.

The renderer that you want to choose depends highly on the rendering time that you can afford (Cycles is slower). Also Cycles allows smoke to emit light and cast it on other objects, plus a few other shading tricks.

I downloaded your version of @eppo’s file, and there are a couple of issues there:

  • you’ve set the emitter to be a domain, so that’s why you lost the animation:


  • the green clouds that you see when rendering comes from the point clouds, and that is not what you want;

To mess around with the smoke color and opacity, you would need a few textures applied to your domain to do so. In fact, the only material that should be present in a smoke should be only applied to the smoke domain, and not the emitter.

Here is a screen shot for the density/opacity:


Example render:


For the color:


Finally if you want to not render the emitter, disable it the particle settings, like so:


Here’s the blendfile with my changes: NC_smoke emitter after NC.blend (875 KB).

Hopefully my screengrabs will help you getting to your goal (and I hope my handwriting wasn’t harsh on your eyes…).

Thank you KWD VERY much. I have been over here for three hours, easy! Going thru settings, comparing Epps’ and mine. before and after. I did not even get to the areas you have shared. Many thanks. I was beginning to wonder if v2.71 is so unstable that I came back here for the eppo file again as the one prior went corrupt (or so I thought) after me finding materials in my smoke emitter domain. Went to check it out via a split screen in Nodes and before doing anything other then as mentioned. Hit F12 to double, triple check and I get a black domain and a white emitter. It’s like a rabbit hole sometimes.
I am going to download your blend thank you go over it with your grabs and the writing is fine. Little “Cari” serial Killer but I will get over it. LOL I write the same way on my pics until I found R.Click >Edit (in Win7) then an editor with font and arrows color choices, etc were discovered.

Thanks for the time you put into this appreciated and grateful. I did not even get an update in my control panel telling me you did this. I found it as I came back as mentioned to GO get the file again as when I close it and hit OK without saving it saves the corruptness or F’up’s I am doing to it… Maddening Man, Regular LSD trip at Lego land…

KWD-

I did Texture Icon> ADD> VOXEL> Color Ramp> Adjusted sliders… My icon stays black. Do you know why?


Thank you…

OH this is how random my version is over here note the screen grab smoke color. Now see my blend file after close and re-open and trying to re adjust the color again.

http://www.pasteall.org/blend/30390

One problem - dissolve time too short on smoke domain causing smoke to dissipate too soon.

Druban thanks for advice I let animation go to end and achieved taller volume.

Crazy thing my post two above about color ramp icon I re-open the file added a 3rd color and now my icon reflects a color?
Crazy man…

Tutti Frikin Fruity…

see pic I did switch the mod after you showed me KWD the difference about textues. I was looking for a beam me up scotty look anyways.


Use cycles for better smoke and fire renders. BI at best does weakish smoke! Although there are some people who can really get great results out of it.

OK so I am trying to Animate and install this smoke sequence and I am getting some odd results…

  1. My smoke in Render View appears more like the Domain then the whispy smoke.
  2. My smoke appears to be outside of it’s domain (see pics)