Help with UV's & alpha on UVs in 2.5

OK, so I was watching a tutorial on how to do polygonal hair, and I managed to model the hair for now just fine.

But I’ve run into a few snags.

When I made the first strand, and UV unwrapped it i paid no attention and just let it not stretch to the entire UV map, like in figure 1. Because I thought it’s be no big deal and I’d just paint a small strand. Well, after I finished the majority of the hair I decided to use a different type of texture, like the one pictured. In this case I needed to strech my UVs out, like in figure 2. I stretched that out manually, however I have 40 some strands of hair right now, and it would be a pain to go to each uv and manually stretch them out.

So, Questions…

Is there a way to make your actual UVs stretch the the size of the image map? (Like in figure 2)

How do you map an alpha transparency in junction with a UV map in 2.5?

I want the tips of the hair strands (where it is black in my UV map) to be transparent.

Please don’t give me links to tutorials for 2.49 or below, because I have watched a ton of them, but since the UI is completely different I can’t figure it out.

Any help would be very much appreciated. I have looked everywhere and can’t find anything relevant for tutorials in 2.5.

does 2.5 have an option for cylinder unwrap? if so, try it on a hair segment, maybe it will work.

Link your material across hair starnda by going in object > Make Link > Material.
In Properties > material > Transparency = check transparency and alpha to 0. (for transparent hairs).
It worked for me.

I actually figured out what my problem was on the transparencies.

Some 3d programs use a map and then a transparency map, but it seems blender lets you just use a transparent PNG. Nifty idea, but I think i’d rather use an alpha map in some cases. Is there a way to use texture & alpha to make a transparency in blender?

Also I’m no really sure if this should go here or in rendering… But here goes.

When viewing my texture in the view port at certain angles you see funky lines like in figure 1. Also, the transparency isn’t really viewing correctly. In figure 2.) A you can see the tips, where the transparencies are supposed to be are just turning out grey. In figure 2.) B you also see along the edges there is some weird gray lines. Now, before anyone asks, I do have premultiply checked. In figure 2.) C I’m setting you up for figure 3. In figure 3.) A&B you can see that when the strand is selected, the transparency works just fine. In both A&B you can see through the trand like you are supposed to, where in figure 2.) C you cannot (As in comparison to figure 3.B )

Now, I read somewhere that if you should always have your shading set to GLSL that it would help with someone of these problems I am experiencing. However when I flip my shading from Multitexture to GLSL, it turns everything, including the model black, like in figure 4. Regardless of that, when I render, both in GLSL mode or Multitexture mode, my render turns out white, like in figure 5. I thought maybe it had something to do with my lighting, so I turned off the rending of all my lighting on the front, and the render is still completely blown out.

use a black and white image of your alpha, put that in a texture channel and set it to effect the alpha value of the material.

Thats exactly what I was trying to figure out how to do to begin with. I might be overlooking it, but I can’t find a place to put my black & white alpha image.