Help with white material!

Hi there, this is my first post on this forum. I’ve been using blender for about 1 month and now i’ve encountered the first big problem.

I made a fan and applied two materials to it. I simply cannot make the rotator blades white. Everything else is already metallic dark. I have googled and experimented with white materials for about 8 hours now and i simply don’t know how to do it. How to apply white material to a certain area of an object?

I’ve tried a lot with nodes, but all i get is grey.
I’ve tried making a monocolored picture and use it as a texture and unwrap for the rotator blades, but i can’t get it to work. Seems like i’m missing different settings from my menus, which ppl have on tutorials. Don’t know what i’m doing wrong.
I’ve tried downloading white materials and used them on my own object. Still grey… Most of what i try doesn’t seem to make any difference. So what to do?

can you provide sample file and show us some pic for render and nodes set up!

did you try to add a bright-contrast node ?

how much light do u have in your scene !

happy cycles

Difficult to guess what you’re doing wrong, you don’t ever tell whether you are using BI or cycles, you should give us more informations about materials and how you linked them to the objects.
The best would be an attached .blend file, if you can do upload it on some site and post the link here, in waiting for your reaching the limit of ten posts after which you’ll be able to directly attach the file here.

Also some screenshots of your material nodes could help.



Okay, sorry for the missing information. I’m using cycles. I don’t have any nodes for the white colored material since everything i have tried has failed. This is how far i came:
I chose the faces in edit mode -> added material -> assigned material. As you can see, it worked with the rest of the fan.

The white color i want on it is about this:
So it is a bit damped, not very bright. Doesn’t have to be that exact color nounce, a little bit brighter would be ok too i guess.

I’m using these lights.
I would say those are bright enough i think. Don’t you?

Thanks for your help. Any good ideas? Or a white combo of nodes, i would really appreciate it. :slight_smile:

Have you assigned Material.004 to those fan blades in place of Material.001.
Is it illuminated sufficiently

Blend file ?

TBH - it’s probably your lighting. A white material will look grey if under lit.

Also - why are you mapping the white image to the blades.

Just open the image in photoshop or gimp - see what RGB values the image has - then apply those same values to the material in blender. You are over complicating things by mapping a plain image map to the object.

edit - I just did it for you - the colour of the image you are trying to apply is f2f1f6. Go into your material - and set the colour to “Hex” - then type in that 6 digit code - that will give your material the colour you are trying to apply.

You are right! Thank you very much! Omg, all those hours spent on trying to fix the problem, all i had to do was to turn up the lighting strength!
Was the first time i was using that kind of lightning, and to me it looked pretty good illuminated. But now, everything else than the objects themselves are completely white because the lightning is so bright, not that i mind it. Everything also became very grey, so had to remake the dark color again, but the white does really look whiter. Guess problem solved, so thanks! :slight_smile: And thanks for the HEX color!

But it made me wonder a bit. Like that, the more lightning the less greyer are the colors. But you can turn the brightness so much up that shadows and edges dissapear, and everything looks like an unrealistic mass. And it’s still slightly grey. Isn’t there an easy way to get optimal coloring and white, like outside in the sun at noon. Because i’m turning the brightness up, and everything looks better and better until it becomes unrealistic bright, like where edges and shadows cannot be seen. And i think it’s hard to tell when the change from optimal to unrealistic takes place, while the greyness declines.

Already said it!
try to add a bright / contrast node and see how it goes
but should be possible to get brighter white !

happy bl

To get the right balance of highlights and shadow - you’ll probably need to have a play with nodes in compositor.

There are several nodes you can use to balance highlights/shadows including Gamma, Tonemap, Bright/Contrast, RGB Curves and ColorCorrection.

Take a look at this tutorial (for the ColorCorrection node). Will give you some ideas on how to play with compositor (but it should come naturally - the nodes work much the same as they do for materials).

Before making adjustments in compositor, I would give a correct exposition to the scene, and set up materials that are physically correct, a kind of, anyway.
For this I would start to tweak lighting without materials, so that a default light grey material is used by the cycles engine, as an alternative you can create yourself an almost white material for testing. BTW, for more realistic result never use full white color for diffusion of materials, even a white material is never 100% white in nature since it always absorbs some light; so for white color use something like (0.95, 0.95, 0.95).
After you got what you think is a good illumination and exposure, you can start to give color to the materials, add glossiness and all needed.

I don’t know whether this is the best approach in absolute, though I think it’s a good start for practicing.


You should follow Sourvinos’ very sound suggestion instead of trying to juggle materials and lighting at the same time.

I would also add that if, as it looks from your screenshot, you are trying to light the inside of a box with HDRI lighting, it is natural that by the time you get enough light on your object inside, everything not inside will be blasted. I know it’s instant gratification but you might want to turn off the HDRI lighting and balance your scene with simpler local lights just to see what you have.

This is the first time I’ve ever seen a cycles scene suffering from bounce light problems that couldn’t be helped by the addition of a nice hdri. DruBan is right. The surrounding geometry would be plenty of environment for that fan. Give it a brighter, plainer external lighting scheme.

Thanks for the tips guys. And the video. I have added a bright contrast node and it became a little better.
This is what i got now. Better than the first one.:slight_smile: