Help >_<

Well you see, I’m making an animation and in it there will be a character who wears glasses, so i’d think I could just set the lense of the glasses material to be transparent and turn up the freshnel and Fac, WRONG, for some reason the glasses are casting a shadow over his face even though they are Supposed to be transparent >_<, help please?

for the material of his face ( the material that recieves the shadow ) you have to click ‘trashadow’ in the shaders panel. and if it’s still not working, try turning up the ray transp depth a click.

click ‘trashadow’ in the shaders panel

If you’re in 2.5x (instead of 2.4x) then in the material settings look under the “Shadow” option and enable “Receive Transparent” (the “trashadow” equivalent in 2.5x).

Here is how to stop being confused about Blender shadows.

  1. There are settings for how an objects casts shadows
  2. There are also settings for how an object receives shadows

Both need to be set when you want good transparent effects.

… and there are also some “funky, but sometimes very useful things” that have no correspondence to “the real world.” Such as, say, “layer lights,” which “see” certain objects but not others. (So, if you want to have Suzanne shining a flashlight through her own head, you can easily do that.)

(Poor Suzanne … she puts up with a lot, doesn’t she?)