Here's another one of those stupid ones!

I just got Blender 2.34 and Yafray 0.7 I am trying to get the awsome caustics to work by creating transparent objects. I know that you have to have a photon light, and a sun light (or other general lighting light) and taht the raytransparent spectral must be 0 but i can’t figure out how to get it to work! I have done everything like a template that does work - i got it to work in the template (creating my own meshes and assigning new materials) but when i start my own blend from scratch it doesn’t work! what could be wrong?

A tut, a link to a tut or a simple explanation would be great! :wink:

okay so no one wants to help! %|

Here is the original blender version i made:

i tried to figure it out on my own and i narrowed my problem down to my material. You see i created my scene then created my glass materials with all of the same aspects as a test blend i downloaded. The result was this:

As you can see the image is okay but there is no transparency to it!

I then appended the material from the test blend (every thing looked the same aspect wise) and then i rendered it again and i got this (the result i wanted!) :

So the answer lyes in the materials somewhere and yet i can’t find it! My spec are:

RGB: .782,0,0

RayMir: .02
RayFres: 0
Depth: 2

IOR: 1.50
RayFres: 0
Depth: 6 (test was five but works either way)

I can’t find the problem anywhere! Oh never mind! lol! :smiley: As i just looked down at the screen i noticed the alpha bar was to 0! that would make a huge difference! I have got to be one of the lamest morons!

So for anyone else who can’t get it check to see if your alpha is to 0! :stuck_out_tongue:

anyone who wants to say “hey moron what were you thinking” can! i diserve it! :smiley: %|

Well, i think main reason for no-one answering is you post title, no body really can guess what you want to ask, if they just browse titles.

but any way.

As far I have understood, in order to use caustics you need to use photons, so, after you press change renderer to Yafray, make a new lamp and go to lamp options, where there is ythis new lamp type, photons. turn that on.

add a lamp, make it photon light. set it so it’ll point to the rings, make the angle as small as possible ( to fit the rings) and render. don’t use to many photons you’ll smell the flowers roots before you’ll se any resault.

yes i understand the lighting issue and i had already set that up and like i said in my second post - it was a material error! thanks for the response anyway - maybe it helps someone who hasn’t gotten it right yet!

yes it was a stupid title wasn’t it?! i don’t know why i did that! :expressionless:

I know! For trans to work, you have to have fresnel > 1 :smiley: