Hey? How come I can only paint 1/2 side of my rocket?

I was following this tutorial, and everything went well until the colors came and ruined everything.

I can paint my rocket on one side with no problem.
But when I try to paint my other side, it just won’t paint!
I’m painting a Cone, one side is painted red, but I can’t paint the other side!

I unwrapped, made a new image! I followed all his instructions!
Help please?

the blend would help to see what’s wrong.

  1. Create Con
  2. select all
  3. Unwrap
  4. Create new Image.
  5. Switch to texture mode.
  6. Use texture painting
  7. Pick a color

What did I do wrong?

maybe you have inverted normals on that half?

No problem here on my end, though your

  1. Create Con
  2. select all
  3. Unwrap
    Lead to no unwrapping being done, as you need to add some seams so Blender know how to unwrap the cone.

Are you 100 % sure the whole cone is truly unwrapped ?

I think I found the problem. I think I don’t know how to unwrap it all.
It looks like I only know how to paint on face.

I re-did everything with a cube. look


For a cone, mark those edges as Seams :

Then press Unwrap

In the UV Editor, select all and click on UV -> Average Island Scale , then UV -> Pack Island
See that the whole UV is not touching the border of the image (can be a problem with paint bleeding) by selecting all and rescaling if needed.

Make sure there’s a little space between the islands too (press F6 just after UV -> Pack Island and increase the Margin if you see each island touching)

edit : looks like imgur has problem, so i attach the picture instead


I did exactly what you told me.
But now I only seem to be able to paint 2 sides.
As you can see, 5 and 6 faces are paint-able,
the rest are not.

Ah i see your problem in your screenshot, you have set “Textured” display in the Texture Paint Mode.
Since several 2.6 release, Textured display mode is affected by light sources.
Meaning that if you have no light, the whole cube would appear black, and if you have a light somewhere, only the face exposed to it would be visible, the other faces are under the shadow, and why they are black.

3 solutions :
-In Texture Paint Mode, instead of setting Textured display, keep it to Solid display, the Texture Paint Mode by default enable “Textured Solid”, even if you have not enabled it yourself in the N -> Display.

-add a Material to the cube and set it to Shadeless if you want to keep using the Textured display mode

-If you want your model to be affected by light sources, add additional light sources so the face that are in shadow are affected and show up

However, when I render, I do not see the color.
What button do I have to press so the cube renders with the color?