Hidden object still showing in redered image

So I made a fluid simulation, and when i tried to render a picture of it, the hidden objects were showing.
How so I hide them INCLUDING in rendered images?

Put them on a layer that you have not set to render in the render settings or in the outliner window click on the small camera icons to turn off an objects renderability

Thank you.