Hide lamps in viewport, keep lighting in rendered preview?

Hi
Is this possible to hide lamps but keep the lighting effect in rendered preview?
turning off lamp visibility or layer visibility also turns off lighting in render.
and the “only render” option in display tab hides wire frame as well.
lamps makes the scene very cluttered i wish there was more options to control lamp display, like in 3ds max.

2.8 has this feature, but in 2.7x you can’t toggle lamp visibility in the viewport and the viewport renderer indepentantly.

How to do it in 2.8?

Did anyone clicked/checked this?

Although, instead of Ornaments naming i would go with Arbitrary - since arbitrary objects are affected.

Thank you all