Hiding collection does not hide all items within it?

When I hide a collection in the Outliner using the eye icon, Blender hides most of the objects within the collection, but not all of them.
I cannot for the life of me figure out why.

  • The objects are not in any other collections
  • They are parented to objects in other collections, but so are the ones that DO hide successfully
  • If I un-parent them from the objects in other collections, they still will not hide
  • All objects in the collection have the same “globally disable in viewports” setting (ie. the little screen icon is on for all of them)

Any ideas what I’m missing?

Unfortunately I cant upload the file.

Anyone able to offer a suggestion? Unable to find anything by googling, so far

having the file to check that is very helpful!

Hmmm, yeah I know, sorry. It’s confidential work that my company owns though (not me) so I can’t really upload it here.
I’ve tried to recreate the error in another file but haven’t been able to so far.

Edit: Ah… nevermind, you wrote that they are not in a second collection.

Yes that’s right, they aren’t in any other collections. Thanks for the suggestion though!

Do they render if your turn off the collections render icon?
Do they disappear if you turn off the collection with the checkbox thingie?

Actually, no, they don’t disappear if I uncheck the checkbox.
Is that a clue?

Well, now it is clear that there is nothing particularily broken with the hide function.

What happens if you hide all collections in your scene?

Have you checked if one of the non hiding objects is really not in another collection:
Properties panel → Object Properties → Collections

I really don’t think it is, unless I’ve misunderstood the panel.
It looks like this:

Yeah, strange. So what happens if you hide all collections?

Perhaps a silly question, but are you holding shift when you click the visibility icon?

No - should I be? What does that do?

So if I uncheck all of the collections, all of the objects in the scene disappear except the objects in question.
They still appear in the outliner, but they seem to be at the same level of hierarchy as the “Scene Collection”. Like they are joined to it by a vertical line, and all the disabled collections are one level down.
Also to be clear, I can hide the objects using their own eye icons - the problem is that they don’t obey the rules of collections they are in. Not sure if I made that clear.

Ah, then they appear to be in the normal collection (Collection 3_Arms) and in the Scene Collection as well.

Viewport → Object → Collection → Remove from Collection → Scene Collection

Probably. It causes the value toggle to apply to the entire hierarchy children rather than just the root. Individual object visibility is a different state to the visibility of the collection.

Nah, if you hide a collection the whole collection all objects inside the collection disappear. The problem is them being inside the scene collection.

Yes - that has solved it! Thank you so much.
For me, was labelled “Master Collection” in that menu, not “Scene Collection” (as in: Viewport → Object → Collection → Remove from Collection → Master Collection). AFAIK I never edited its name, and it still says “Scene Collection” in the outliner. Bit confused by that, but glad it works now!

So is there an easy way to tell whether an object is in the Scene Collection? Since it doesn’t appear in the Collections part of the Properties panel. *EDIT: actually I guess I’ve already answered my own question above; you can tell because they are at the top level of hierarchy in the outliner.
But do you know how the objects would have ended up there?

Hmm… it appears that there is some naming bugs.
In Blender 2.9 it was called scene collection but in some places like the “remove” dialog it was still called master collection. This was corrected in 3.0.

How it ended up there is something you can only guess.
Perhaps you created it there and then instead of moving it to the other collection you linked it to the other collection. Linking it to the other collection puts it in the new collection but also leaves it in the old collection. Shortcut for moving is “m” shortcut for linking is “shift m”.
Or you moved it in the outliner and accidentially pressed ctrl while moving it. This links it as well instaed of moving.

Okay, well I didn’t know any of that stuff, so definitely good to know!

Thanks for the help