Hit the wrong key!

Hi folks, another newbie here. I’ve been working on a tut of a spaceship. Doing pretty good until I pressed the wrong key and this cube popped up around the front part of the ship. Not a solid cube but tranparent and drawn with orange dashes. Anyway, I can’t get rid of it. Tried everything that I know to do and it won’t got away. Can someone out there help?
Thanks, Jerry

You probably pressed Shift+T
In the Object Data (triangle button on the properties window header) settings tick ‘Auto Texture Space’ in the Settings panel.