Hollow Misc

Hello,
I have modeled an aircraft with a solid fuselage. However, when I tried to cut a part of the fuselage, the fuselage now seems to be hollow with only outer shape and a thin sheet of misc in the middle. Could anyone help explaining:

  1. Is this hollow or not
    2a. If it is hollow, why is it be hollow as I used a normal cube at the beginning and if there’s a way to make it back into a solid again, as I don’t want to model the fuselage again.
    2b. If it is solid, why I cannot use Boolean to cut the section out as usual.
    Thanks in advance!

You need to show us what you’re trying to do.

Oops sorry, the photo is not uploaded for some reason. I’m trying to make the nosegear and cut a hole in the fuselage for the gear.

I can’t really see what you mean from that pic. And what do you mean by “sheet of misc”?

You need to explain what you are doing and show the problem better. Give us a screen shot of the hole in edit mode with the edges highlighted so we can see what you’re talking about, and make sure we can also see your modifier set-up.

What I mean by a sheet of misc, or a sheet of… whatever, is that… it’s a thin layer of stuff, not a block. I literally have no idea how to explain it. I cut the aircraft so you may see what is going on to the fuselage. I made the fuselage out of a solid block, but now it’s like this.

I meant to cut a space out from the fuselage as shown in the photo, but the result of the cutting ends up like the second photo which I’ll upload later.

Objects are hollow. If you remove a face, you see the interior. If you wish for something to be in that space, you need to model it. The solidify modifier comes in handy for giving some thickness to the “sheet.”

Here’s the photo of the shape after the cut. The wall of the area cut is gone.

Thanks for the reply. However, this is not what happened when I was doing the windows. I made a block same as the shape of the window, used the Boolean Modifier to delete the “difference” part, and all worked well, and the window face appeared as usual instead of cut straight through the face. Here’s the photo of the windows.

With a boolean modifier you have added new geometry - the other object in the boolean. this defines the final geometry - vertices and the faces in between them. If you apply the modifier and delete one of the “window” faces you will see it is hollow inside.

Another way to look at this is to contrast “solid” objects with volumetric objects (fluid, fire, fog, …)

To create fog, you can take a cube and add a volumetric material to it. This material has a density value, and when a light ray is passing through it, the renderer can calculate what it “hits” as it travels through the volume. If you take a cube and give it a surface material, the light ray returns information when it hits a surface. If you remove a face, a light ray can pass by where the face was and travel to the inside surface of another face, and return that info (with normals in the wrong direction, I should add). Until the ray hits a face, there is no information; there is nothing inside “solid” objects.

This is a feature, not a bug. If you model a rock, for instance, you do not care what is “inside” of it - that will never be rendered. Including information for the inside of objects would add a lot of data points that would never be used.

That ‘sheet of misc’ is a face.

Nothing is actually solid in Blender. Objects are made up of faces, so a cube is just like a box with 6 sides.

If you go into edit mode and highlight the area where you cut it away, and explain what you did to get what you got, I can maybe help. Can’t help much without that.

Okay, I get the idea that you’re using a solidify modifier and think that it solidifies the entire object, which is not the case. The solidify mod just adds a second face on the inside of the object so it’s like a wall with space between. What I think is happening is you’re using a boolean to cut through both faces and ending up going right through. You need to turn off the solidifier before applying theboolean, and it should work. You can turn the solidifier on again afterwards.

Let me know if that helps.

I realized that your question may have been answered, but it did not necessarily solve your problem - which seems to be how to add a bay in the fuselage for the landing gear. I suggest using the extrude tool (in edit mode, select a face and press “E”). After pressing E, you can just drag you mouse to determine the direction and distance, or you can type in a number (0.5, -3, 12.25, …).

So rather than deleting the faces where the bay should be, extrude them into the object. This will create side and back faces for the bay. Adding loop cuts to define more faces, and then extruding these faces will give the shape you want. This is easier to show than explain, so let me know if you need further info.

I have not used the solidifier in the project… I did nothing except building the fuselage, creating another cube and overlap it with the existing fuselage, add the Boolean modifier, and then apply it. Here’s a photo of what I have after the modifier.

Sorry for the confusion - I brought up the solidify modifier. I do not believe the OP was using it.

Thanks for the suggestion. I’ll try your way ASAP, as I have to leave the computer now. Will get back to this as soon as I have access to Blender and free time.
Thank you!

Hello,
I have successfully fixed the issue with the method you provided!!! Thank you so much!