Hope this is right area

I trying to install this add on WASP MED Add-on Blender 2.8 and i install it though add ons and when i click on it to activate it i get this error message

and dont know how to fix this and hope that someone can help

I’m not familiar with the addon, but it looks like a broken reference. Potentially something needs to be changed for 2.82.

To get support for addons you should contact the addon developer directly because it’s very unlikely that they’ll see this thread.