Horse Model and Rig

This is a model and rig I have been working on.
I will call this version 1.0 because I still have morph targets to make and the neck is not very practical

I used this horse in a project I finished for The CGSphere competition. You can see it in this thread

nice model.

Here are the .blend files.

You will need WinRAR or 7Zip for this one. 379 kb

p.s. The rigg now works perfectly in 2.43

wait…you’re giving out the blend file?

Whoa… you’ve been working on this for a really long time. I remember the rig from when I was just joining the community 9 months ago :eek: This is an amazing rig, thank you very much for sharing it!

That’s not good … for Blender developement that is … 2.43 should support any rigs that were created in 2.42 … or even 2.41. I haven’t found any yet that don’t work in 2.43

What isn’t working ?

Have you submitted a bug report ?

What has changed in this version … since the last version? (user level changes? … “internal” changes?


mike_s: he has submitted a bugreport. Unfortunately, I cannot figure out what’s going wrong in that file, but it looks like some mesh-related issue.

Basically, what’s happening is that the the vertex groups don’t seem to affect the mesh no-matter what you do to it. However, there is this odd deformation that occurs to the middle of the mesh.


So far as I can tell, the odd deformation seems be a couple vertex groups in the spine that are still functional.

Heh… seems I spoke a bit too soon.

What the problem seems to be is that there’s this vertex group with no name, that does not show up in the popup menu. This vertex group only contains verts which occur in the region that gets oddly deformed. Now, because there was an option added in 2.43 to allow you to define a vertex group which the armature modifier will work in, this nameless vgroup was mis-identified as the vgroup being used for that purpose.

Workaround: assign all the vertices in the mesh to a new (additional) vertex group, and give that to the armature modifier in the VGroup field.

I’m fixing this issue now.


Catboy 85: WOW, wow, wow!!! This is really excelent work! The modeling is perfect, realistic, yet workable with the armature! I can really say this is a great achievment! Well done! (would like to see it textured and maybe some hair?!)

Aligorith: Thankyou, I fixed the problem by simply deleting the vertex group with no name

Siluno: Thanks. I do plan on texturing and adding hair using jahkas particle patch

Alden: Yes it has been a while:rolleyes: but this has been one big learning project. I even developed a new type rigg for the spine that works well in quadrupeds (atleast I think it’s new).

Here are the fixed files


Hi Catboy85,

Thnx for sharing this .blend…I’m gonna use this for learning reference in rigging…

Aligorith, FYI
I don’t see a no name" vertex group, but there was a group called “93”, in the popup. When I selcted that group, the vertex group input box was blank, I filled in an arbitrary name and that fixed the problem.

Uh can you rephrase that? … I have no idea what you meant :slight_smile:


Thanks Catboy89, your effort and generosity is much appreciated. Here’s my first render after messing with the model for a while (most of that time spent making a tail that almost behaves :slight_smile: )

Thanks, and thanks again.


This rig seems to get better and better each time I see it pop up on these forums. Good work!


ecgilboy: Your welcome.

AndyD: Nice pose, and good hair on the tail.

I will be adding a full facial rigg soon and dynamic hair using jahkas particle patch:yes:, But first he needs a good fur texture

that’s really good looking, i wish i knew how to do any of it. All i can do is basic bones. It’s a really good looking model. I think i may use it in a Don Quijote scene i’m working on, i’ll change this a little and make it look like rocinante!

I downloaded this model and i like it :slight_smile:
could you get a blend of the same model but like its not in a pose?
as then working with it would be alot easier :slight_smile:
otherwise w00tage!

To clear the bone positions just hit alt-g to clear locations and alt-r to clear rotations, then you are left with a set of bones in their rest positions

ahh ok thanks