Hotket Preset Issue

Hello all. I am a former Maya user that has recently switched over to Blender. I have been using the Maya hotkey preset and have had no issues until I was modeling a project tonight and needed to separate geometry from one object into two separate objects. I know that Blender default is P to separate but the Maya preset for this action is not working. I have tried to rebind the command to different keys with no success. Also, it seems blender does not want to unbind P for parent in Maya preset for some reason. I did find it strange that reverting all keys back to blender default solved this issue and I was able to use P to separate. I really need to rebind this as it makes modeling just impossible for me as I use this command quite often to separate geometry. I am hoping there is a way to manually change this in a configuration file somewhere. I hope I explained my situation well enough and hope to solve this very puzzeling keybind issue. Any help is greatly appreciated and thank you in advance :slight_smile:


read post #3

similar problem who use preset ( Max )
its a bug

my solution or temporary workaround

Solution :

start blender => restore default setting

after that go to
input editor > use preset > blender ( default ) and reconfig all manually hotkeys to make it maya

it will take a lot of time ( but it will fix the problem )

and do not create a custom name preset or you experience again the bug later on if you make tons of changes to hotkey

Summary
the max & maya preset or any custom name preset always overlaps with blender ( default )
thats why you really need to start from blender ( default ) and just change it to maya style navigation by manually locating and changing all shortcuts

yes its very time consuming but this is only the workaround as far as i know.

Thanks so much for the reply. Well, if that’s what I have to do to fix it I will. Hopefully there will be a fix for this in the future. Makes binding keys a pain but I guess that’s how the cookie crumbles. I appreciate your help and thanks again :slight_smile: