Hotkey F: Make Edge/Face | 2.90 | Neglecting Priority Convention

I’ve got a discrepancy and a time loss problem:

At 1:40 in this tutorial the modeler uses “F”; Make Edge/Face, to fill out, from an edge, faces between two strips of them. When attempting to do this myself it did not do the same, now, in 2.90.

Am I doing something wrong? I hope so. I tried Ctrl+F, and Alt+F options and explorations coming up empty handed.

image

I can fill all the way out from the elbow vertices, but I don’t want to have to delete the interior triangle every time. How can I get back this (apparent) loss of tooling?

I believe he is using F2 addon in that Blender version. This feature seems to be working by default in 2.90 version. You just need to select edge, instead of vertex.