hotkey problem

for some reasons the hotkeys on my number pad aren’t working, which means I can’t find a way to get on to camera view. What’s the non-hotkey way of doing this?

Is your numlock button on?
In the user preferences you can select Emulate Numpad which makes the keyboard number keys act likne the numpad keys. You can also select your view from the 3d view View menu

whoops, numlock hasn’t been on. Bit of a silly mistake, sorry to bother people.