Hotkeys with two keyboard layouts

I’m just starting to learn blender, and I have been having a really hard time getting hotkeys to work in ubuntu. The reason for this is because I have dvorak as my main keyboard layout, with qwerty as my secondary. When I start blender, I switch to qwerty so that the hotkeys will be in the correct spot. However, even though I switch, it still seems to think that I am in dvorak. The text inputs (like naming an object) work fine; are in qwerty. The hotkeys still seem to be in dvorak though. Is there any way to fix this?

Why do you want to pass in qwerty layout to use Blender if you are used to using a dvorak keyboard ?
I use a French azerty keymap myself and I’ve never had any problem, obviously the shortcuts are not placed at the same place but, in my opinion, it’s not a problem since most of the shortcuts are created from the first letter of the action they will do.

My keyboard is a qwerty keyboard, and I only have text typing memorized with dvorak. With hotkeys, I always look at my keyboard. Because of this, when looking at my keyboard it always takes me a couple of seconds (real seconds, not a figure of speech) more to find the hotkey in dvorak than in qwerty. Also I have been using it in windows on qwerty, so I am used to it that way.

Ok, I believed that your keyboard was a real dvorak keyboard.
This problem looks strange, now I’m using fedora but, before, I used ubuntu for a quite long time and I’ve never seen two keyboard layout active at the same time.
On the other hand, my keymap switched some times when I pressed the shortcut to change the keyboard layout without meaning to.
I can’t remember this shortcut because now, I use only one keymap but perhaps your problem has something to do with that or else I don’t know.

The default shortcut to switch layouts is left+right alt key, but it didn’t work, so I changed it to right shift+ctrl. This woks fine for switching layouts, although I normally use the applet in the notification area, which works perfectly as well. All the applications take the switch, hotkeys and all. When I start up, the applet says ‘USA’ (which means dvorak) and when I either click that or hit shift+ctrl it changes to ‘USA2’ (qwerty). Blender takes it as dvorak when the applet says either.

I’m guessing you tried switching the layout system wide first then start Blender? It seems like you are switching the layout after Blender is already open.

Well I have tried both. The result is the same.

Blender has always behaved this way for me (at least since 2.49) in linux (kde). I’ve learned to translate the key positions in my head when I use a keyboard that isn’t layed out “correctly”. For my own use I have an Apple keyboard where I physically transposed the keys.

Could this be considered a bug in Blender?


I have exactly the same problem (same symptoms) as the OP.
I have opened a ticket and will post the answer there if I ever find a solution: