How can i access the Blender 3d connexion setting menu?

Hi again guy’s,

I know i am asking a lot but i am giving a second try at switching to Blender from 3ds max.

I am using 3DxWare64_v10-5-8_r2793(the latest)and i cannot get the menu that is shown here ;

I want to deactivate the show navigation guide that draw a blue line each time i use my space navigator.

Clicking on my space navigator button show no menu at all!

I am using Blender 2.79.

For some odd reason after re starting Blender the menu is now showing!
But i would still like to know how to do it!

So if I understand you correct the menu is now showing and you can turn off the ‘show navigation guide’ option. In other words your question now is how to save the setting persistently? File > Save startup file (or Control + U) should do it.

Hi Felix,

I know how to save the setup but i still don’t know where in the blender user preference to make the 3d connexion menu show up!

By the way the menu just vanish again without me touching or changing anything.

Well, since I don’t own a 3dconnexion device I can’t really help with that. Perhaps if I had access I could try to look at the script but that would likely take some to go through too.

Thank but i am not programmer so i am not going to dive into this!

If anyone stumble upon this thread here how to get that NDOF menu back ;

Step 1: Open User Preferences
Step 2: Under the ‘Input’ tab, expand ‘Window’ then scroll down to ‘Call Menu’ [NDOF]
Step 3: Change the keypress to one of the buttons on your spacemouse.
Step 4: Save User Settings

Regarding step 3 i don’t know how to assign the keypress to my space navigator since clicking on both buttons of my Space navigator do nothing so i just assign the letter D and finally i have my menu to change settings.

1 Like

If pressing menu through the 3D space mouse doesn’t work.
1- Open blender.
2- Open 3Dconnexion Home.
3- Open settings from 3Dconnexion Home.

4-(Alt+Tab) to switch to blender as fast as possible, So when the settings is launched it finds blender so it opens it’s menu settings.
Note:- It’s a tricky fool way, But it worked with me.