How can I fine tune these shadows

I have 2 images here. The 2nd has a single plane with emission which casts a soft shadow. The 1st image has an added sun lamp with a size 0 casting a sharp shadow.

I would like to only have the shadow from the lamp. How can I set this up? Also, I had to set the lamp light to 0.200 because at 1.0 it was too bright and it interfered with the scene. Is there a simple way to make the lamp cast a sharp shadow without brightening the scene?

I’m familiar with nodes but I have very little knowledge of them right now. So to summarize, I want to make sure that only one light source casts a shadow (a lamp) and other light sources (emissions) illuminate the scene, but don’t cast shadows. I’m using Cycles.

Here are the 2 images

Attachments



if you just want to brighten a scene without shadows just use environment lighting.

Not just the scene, but better control of the shadows. I need a very dark and sharp shadow of the table, without washing out the rest of the scene.

wineandcheese-
m9 is spot on- that’s what you want to do for easily bringing up the lighting intensity of your scene. For better control of shadows, I’m partial to the area lamp in cycles. Bigger lamp=more diffuse shadows. Smaller lamp= tight, crisp shadows. Just play with the scale of the lamp a bit. You’ll find your sweet spot.

Here is a Sun light set to a Size of 0.001. NOTE: You only get this option with actual Lamp objects. Emission based meshes do not have this feature.

Attachments


Use suggestions as listed above.
With your preferences try setting the sun to not cast shadows (+ add env.lighting), then add a lamp enabling “only shadows” (spot, sun, point, whatever). This should give you enough option for finetuning since the lighting and shadow are separate.

Alright, I tried a few different ways and it works out so far, but I don’t have fine control so I have other problems. The last recommendation was to set the Lamp to shadows only, but this is not available in Cycles, only in BI. Is there a way to do this with Nodes? If yes, could someone give an example of how I would do this?

Also, other problems I have, that are not part of the initial question, but related to lighting is color bleeding. I might have a pink floor and a white ceiling, and as soon as it’s rendered, the ceiling is pink also. Setting Diffuse, Shadow and Transmission for the object, on and off does not make a difference, so I have been playing with the lighting. No success yet with the settings. Here is another image. Note, that in this image, there is no ceiling. I have 3 planes set to emission from above the room and 1 Sun Lamp with a low intensity to cast the sharp shadow. Overall, I have really good illumination, but slight adjustments in lighting that are necessary when adding objects, can really make the intensity too high. I don’t want to fixt that with a post process. It has to work with the intitial render. If I add a ceiling to this scene and point the camera up, the ceiling object has to be set to Shadow off, to allow the planes above to light through. I have all kinds of light collision problems. So this is turning into a second question, but if someone has input on this, I would appreciate it.

Attachments


If you try to ‘trick’ lighting you will end up with un-natural looking scenes. For instance, the ceiling in my house is painted white. When I turn on the light in the morning, it looks kind of yellow due to the type of bulb I have in the lamp on my table. This is the way light works. So if you don’t want a pink ceiling in your scene remove the pink floor.

“Less not more” - The Residents