How can I fix noise and other problems with Cycles?

Hi guys,
I played a little with Blender in the old days, but had a pause of 1-2 years until now.
I’m fiddeling a little around to test the new features. This new engine Cycles seems nice to me, but I have some problems with it. Can someone please help me?

  • I can’t use the GPU in the newest version of Blender (2.65). There isn’t an Option for activating it. I tested the 2.64. I could activate the GPU there, but it wasn’t really faster, plus crashed often. I have an AMD APU A8-4500M. I think I read something, that ATI/AMD-Support is not very well, but will it get better or is it a bug?

  • I wanted to create a scene with sun falling into a dark room. I designed a test-scene with some watery-looking elements, but I have a problem with noise and performance:

  • Even with only the room and the suns I get too much noise. I tried turning down the exposure-time and turning up the bounces and runs per pixel, but it didn’t really help. What can I do to prevent that?
  • The rendering is incredibly slow. I know it’s because of my bad hardware (It’s a laptop and I only use the CPU…) but I think that can’t be the only problem. Are there some options I can optimize?

Thank you for helping.
Have a nice day!

Greetings

bubble.zip (1.51 MB)

there is no point in trying to use a gpu if it doesnt have cuda and AMD/ATI cards do not have cuda
this is how cycles works it gets less noisy over time
http://www.blenderguru.com/4-easy-ways-to-speed-up-cycles/
this should help a little but cpu is going to take forever unless you have like 16 cores or something

Try to put some lights into the windows like portals. (you can set them invisible for certain kinds of rays, so that you can still see outside and invisible and let the sun light in). Turn off caustics - cycles isn’t good with them at its current state, try clamping (in sampling set it to like 2 or 3), and finally use filter glossy with values starting with 1 and higher.

Very hard setup for path tracer, you need many bounces (>4) just to go penetrate 2 bubbles, you need much better CPU for that. Imagine, every sample it make ray from every pixel, and search path up to 8x+ bonces or it hit background, every impact it probe shadow for 3 sun light sources. Huge amount of calculations.

Use as less light sources as possible, maybe just background. But anyway, after ray penetrate bubble, it will have very small probability to hit background (as windows so small compared to open space). You need something like photon tracer (as Yafaray) or MLT based render to render that scene in reasonable time. Best Cycles friendly setup - shiny glossy car on open plain, with only light source as HDR background.

Hi again,
I tried some of your advices and it seemed to speed up a little. But the general problem remains the same :frowning: A little help with gimp reduced the noise, but it’s still too much…

  • Would it help to reduce the faces on the objects? Or doesn’t this change the speed notably?
  • Do you know maybe some tutorials on this kind of setup? (Sun shining through holes and windows in a dark room.)

Greetings

P.S.: Don’t get confused by the render time. I use the laptop I mentioned above for modelling. And usually an even slower one for rendering (Dual-Core Amd + ATI Graphics Card). This time I had a little more time, so I used the working station for rendering, because it’s faster. But as it says I need to work there, so I can’t do this often :frowning:
P.P.S.: I can’t upload now. I will try it tomorrow again.

bubble.blend (961 KB)




It’s simply a difficult lighting situation and will require more passes to clean up.