How can I get my image plane FULL transparent?

I have been having this problem for a long time in blender and have tried to work around it but its really starting to bug me.
I’m trying to make a cardboard-cutout-style scene but a problem I keep running into is that whenever I make an image plane and make it transparent so I can put a png image onto it I always seem to still see the square plane shadow being lightly cast when its at a certain distance from the background.

Heres what I mean:

See how there is still a square shadow around the tree?

I’ve also attached the blend file if that will help.


cardboardTree.blend (432 KB)

It’s not a shadow it is the ambient occlusion settings you are using. AO doesn’t care if your object is transparent only it’s position releative to other objects. You can change the AO distance n the Gather settings. This is a global setting. Otherwise use render layers and the compositor to build your scene.

Turn off AO and use the soft shadow settings of the light to blur the raytraced shadow.

if the background is an object, go to the materials and under the shadows tab, tick receive transparent.
Hope it helps.

Okay so I turned Ambient Occlusion off.

Although that does get rid of the problem I’m still not getting the nice lighting that I would get if AO was on. How would I be able to achieve the same/similar lighting with AO off?

try turning AO back on, but on the alpha plane turn the ambient value to 0…

doublebishop: That sounds like that would be the problem but unfortunately even if I turn the ambient value to 0 I still get the same thing :S

Richard Marklew: Okay so the composite work around does produce the right result but I feel as if I still didn’t really fix the problem. What is it in the AO setting that seems to keep affecting transparent objects? Why would transparent objects produce an ambience anyway (especially when I put the ambient value to 0) ? Thank you, though, for suggesting the composite work around. That really helped. But I still don’t feel like I can claim this problem completely solved yet.

Oh and I forgot to say (since you can’t really see from the screenshot) that I changed the background plane to Shadows Only and from Shadows and Shading to Shadow Only in the drop down. That way it comes off as ‘invisible’ but the shadows are still cast.

I think your solution is about as good as it gets with Blender Internal. No one is actively fixing this problem. Wait till you try making a floor reflective and receive shadows only along with AO. Another bug creeps up. AO can not pass through anything that needs to be raytraced.