How can I have Alpha 0 but only shows highlight

couldn’t find tip on this. Maybe I was using wrong search terms.

I want to create “cartoon glasses”. By that, I mean, a plane that is completely transparent, has no refraction effect, but we can see it’s glare/highlights only.

When I apply “transparent” the highlights also lose their strength. If I use glass in Cycles, it distorts the pass-through light realistically (I just want it straight though, like transparent/alpha). If I use Evee — well, Evee’s a mess when it comes to glass. But I want the glare to move/live in the scene, not just be an image PNG pasted over it.

I’m still pretty basic in my Blender.

what about a mix between a Glossy and a Transparent node?

Try this: NPR Glass.blend (738.4 KB)

You need to use it in EEVEE so you can have the Shader to RGB node.

The basic idea is you take the reflection from a specular shader by the Shader to RGB node.

I added some crazy effect animation to the shader so you have to be careful if you reuse it. It was originally made for @gneogal project.

I think another 2 simple manual method (Eevee) you can use.

This is so close. Unfortunately it casts a shadow & the resulting lines are too plentiful. I’ll see if I can understand the shaders by messing with them.

Is there a place to turn off shadows by only one object? That would solve the first issue.


1 Like