How Can I maintain a flat world background in Blender


I want to chroma key my blender animation. How can I stop blender from altering
teh background key color around the model.

ie: I make my word color blue and my model is just an object moving over
a blue background.

I’m not sure if the problem is the AVI jpeg or the way blender is rendering
around the object, but I get clouds of ‘off-blue’ pixels near teh edges of the object.

Jpeg quality is set to render at 100%. Not sure what else to try.


Just tried AVI raw and there are still clouds of ‘off-colored’ pixels around the object.
I wonder if it’s the mpeg encoding in the AVI output. Is there mpeg encoding in the AVI
files output by blender? (ffmpeg seems to think so)
Is there a way to force mpeg to encode without any compression?

Maybe ffmpeg is the problem…


I’m sure the cloud around is done by eavy use of Anti-aliasing. Anyway you don’t need a blue background and chromas key if you render you perso directly from blender. Use alpha channel! in render setting, press RGBA. render as tga, jgeg will compress even if your at 100. and then in the sequencer you’ll be able to do a “alpha over”. Your perso over your real footage aka background.


I’ll look at the alias settings. I htought I turned them all off…

Does blender render chroma key over real time video?
I’m using blender objects chroma keyed in a video renderer.

It would be pretty nonproductive for me to break the live action video
down into frame by frame tga or jpeg images. There are just too many


The Blender sequencer will handle alpha channel tga or png sequence files, as well as full motion video. The output will be as expected, if you alpha over them. There is also a chromakey sequence plugin available in the standard Blender plugins. If it’s not there, do a search and you’ll find many threads on the subject.

Yes Blender do chromaskey with a sequencer plugin though it’s not the best chromas key i saw. And using the sequencer, you can use a suit of images file like images000.jpg, images001.jpg… or any other video format blender support. (you can see the list in the render setting, in the drop down menu). I told you tga or targa, becasue this format support Alpha channel.
So there is no need to break foatage in frame… as you can import the entire video in blender sequencer. just do add >> movie.

I thought I was must be missing something…
I don’t have a sequencer plugin.
Where do I get the plugin?

Is the alpha/chroma key better in blender or cinelerra?
Cinelerra also does chroma with a series of frames.

I thint I can also use a passepartout series to mask in Cinelerra.
Maybe an extra step , but it might clear up the edges…


also, try premul or key [bottom of the render tab in the render buttons] instead of sky

blender will blend the color of the edge of an object or translucent faces with the sky color if you have sky chosen. This means that when if you look at the alpha channel, the edge of your object will have the wrong color slightly

premul makes the sky not render, and I’m pretty sure it also multiplies the translucent pixels by the alpha value [makes them darker]. Some systems may require this [it is an optimization for an alpha blending equation], but I’ve never used any that did.

Key will cause the world color to not alter translucent pixels, but it will show up on any that are not translucent

I think you should use key, rgba, and a sequence [a file for each frame] of tga images. You will not loose anything because of compression [jpeg is evil] and you ought to be able to do the blending correctly in any decent application that works with video [it ought to be able to import a sequence too…].

besides, using avi raw you’ll reach the 2Gb file limit fairly quickly [also, some filesystems [like fat32] have a 2Gb file size limit on their own]

not passepartout…

Me Wrong.



I have been using the key setting. It seems to give me the same
output. possibly because the background is turned up so high it doesn’t make
much difference.

I have EXT2 file system. Am I 64bit file size? I’ll have to check on that…
I have some files bigger than 2gigs…

I think I may have to switch over to raw frame rendering with the chroma key
that I am using. Maybe the mpeg encoding is causing the aliasing.
I thought it was some kind of motion blur at first…

Well, gotta sleep now.

Thanks for all the info,
Maybe I’ll just keep putting my notes in this thread…see what happens