How can I make textures look pixelated?

Hey guys!
Is there any way to disable texture filtering so that all textures in the BGE look pixelated instead of interpolated (like in a good old DOS-game!)?

Thanks in advance,

Sure, just pull each image map into an image edit program.
Then resize it to 50% original size.
Then stretch it back up to 100%
Save the image map out and it will look more pixelated.

For extreme pixelization try downsizing 25% then restretch to 100%.

Thanks for the reply -
But I just wanted to keep the total filesize of the game as small as possible, so using 64x64 instead of highly pixelated 1024x1024 textures would be waaaay better…

Lol Atom, really?

tloz, what you’re looking for is disabling mip mapping. It’s in the preferences tab somewhere.

Awesome, thanks!

Just one more question:
If I would create a BGE runtime of a game now - with mip mapping disabled - does this effect also appear on an other computer?

No, you would have to start the game with mip-mapping disabled. I made an example file that did it all in Blender, but it didn’t work in multi-texture mode.

I did not say to make it 1024x1024. I said to keep it at 100% of original size.

So in your case, I would open up that 64x64 image in photoshop.
I would create a new 64x64 image.
I would resize the original to 16x16
I would drag that 16x16 layer into the 64x64 new image.
I would then stretch that 16x16 back up to 64x64.
Save image and done!

Same image size, but pixelated.

Turning MIP off is only going to get you so much. Using the above method, you control exactly how much pixelization occurs. I have seen some really nice work done with way. Exteme pixelization stretched back up.

Well, the ( fabulous) Gimp, have a nice “Pixelate” filter, maybe useful?!

It’s not really that I want the textures to be pixelated and I also don’t want to loose quality (therefore: NO resizing and NO pixelate-filter), I just want to get rid of the interpolation - which can be achieved by disabling mip mapping…
But it really doesn’t make any sense, if this doesn’t work with the finished standalone-runtime game.

Hey, but anyways :wink:
Thanks to all who have answered!

I’m pretty sure you can disable it for the blender player. There are some flags you have to set.

I believe this is it:

-g nomipmap

another edit: It would be awesome if someone wrote a 2d GLSL filter that pixelated everything.

Dmills is correct. You know, I wrote a pixellization script. It works pretty well.

EDIT: Here’s a picture of it. There’s some artifacts that I plan to fix today or tomorrow, before I release it in a big box of post-processing goodness.

(There’s also a radial blur applied).

I’m working with Windows, does it mean I “just” need a batch-file to deactivate the mip mapping?
And how would this file look like?

I tried it with “game.exe -g nomipmap” but this didn’t work.
I’m pretty sure that what I wrote is wrong though :wink:

It should be “-g nomipmap = 1”.

thanks, it works now!

No problem.