How can I make the 'random' actuator never do the same number twice

I have a random animation setup on a true level triggering of 5 so it won’t look like the exact same animation over and over if the pulse is going for a long time and when the random generator makes the property the same twice in a row the animation finishes before going to the next one that overlaps it and makes the animation look jerky and bad, so I was wondering how I could make it never have the same number twice in a row

It’s in ‘int uniform’ mode and it can be between 1 and 3.
The animations are 13 frames long and do not have ‘continue’ ticked.

store the last chosen number in a property. If the new number and the stored number match … increase the new number by one.

problem: the number after the stored one has a likelihood twice as much as the others. And you need ensure not to leave the value range.

Other option:

The random value range is one less then numbers of actions
If the new number is equal or higher then the stored one increase new number by 1.

Ask the user for a Seed integer, or increase by using microsecond

it sounds like a good idea but I don’t know how to have the last number as a property.