How can I render the background with an alpha=0 ?

Hello !

I would like to render an object to png and only that object, so that everything else in the picture is considered as alpha in my png output.

I have tried to play with the ID mask but haven’t succeded yet.

Is there a quick fix somewhere ?

Under the Scene (F10) Menu, change the format of the image from jpeg to png and then under “Render” change the settings from “sky” to “premul”. Hope this helps!

Hi blndr08: I thought about png, but had no idea about this “premul” thing.
I’ll have a go , thanks !

Or… under the Scene (F10) Menu, change the format of the image from .jpeg to .png and then under .png enable RGBA.

You can use any file format that supports an alpha channel - .png .exr .tga…

Excellent: that works like a charm !

Another little feature learnt…
Thanks to both of you

A litle trick : If you want to cut out a “hole” in your picture, with 0 alpha value, you can create a shadeless object (mesh) with 0 alpha value, and the Z buffer disabled for this material. The object will be unvisible and everything behind your object will not be rendered and will have a 0 alpha value in your final image.

very nice tip roubal, i tried something similar before and i had to resort to using a complex renderlayer to do it>.<

also, for myself, i found just deleting the world material and setting my output to rgba does the trick for me.