How can I use nodes to fix alpha shadows ?

I’m working on a bunch of images with alpha shadows for a game, but the shadows I’m getting with the 'Only shadow" setting in shaders is only giving me very faint shadows,(alpha = 10 - 60, I need 155 ). I’ve tried everything I can think of, but no luck.
How can I render darker shadows?
And how can I use nodes to darken the shadow alpha of images that are already made?

( using Blender 2.48 / Linux 64)
edit
Shadows work properly for sun lamps, but never for spot or normal lamps.
Those used to give me dark shadows in earlier versions, I think its a bug, possibly specific to linux.
I’ll re-read the docs on nodes and see if I can make this node setup work properly too.

Attachments


NodeTest.blend (167 KB)

I figured out a node setup to change alpha values in images. Its rarely needed, but just in case anyone else needs it, here is how it looks.

I’m still having trouble. I can make a new scene with all shadows working fine, but if I open an older file made with 2.37 (or thereabouts) the shadows alphas values depend on the spotlamps distance settings!
I know few people need to make images with alpha shadows, but has anyone else seen this problem?

Attachments