How can this adding object problem be solved?

Here is my setup but there is a slight problem as you will see. I add an object to my scene ( a light) the K key deletes the light L key adds the light as you can see from the setup. everything works fine except this problem. If you hit “K” 4 or 5 times is will allow you to add 4 or 5 objects not just one. No one would do this except by accident. Look at the image. Can this be fixed so only one object is added? This only happens if you hit the delete key more than once and if you hit the L key more than once


maybe try to delete the “L AND” from the expression, for me this part seems useless, but it has potential to be the problem, because “L” is no variable (my guess), so the result of the expression is always the same.

Toggle “tap” on the keyboard sensors!

Is that screen shot really your setup?
Because it should work so.
Maybe you use in your right setup a “Add” and not a “Assign”.


Light.blend (125 KB)

but “tap” won´t prevent you from tapping the key multiple times

Blend file please!

This is weird. That screenshot is mine but I must have changed from add then made the screenshot because it works with assign. I had made a new blend to experiment getting rid of my problem/, I looked at the problem blend, it was ADD like HG1 suggested. I had this problem for months but never bothered with it until yesterday. I must have fixed it without realizing it. I was making many different attempts failing with every attempt, anyway now it works.:o:o