How - disable shadow single object - yafray


Take a look here:

How do I get rid of the shadow on the background?

These are the material settings:

I also tried moving the background plane to another layer and click the layer button on the lamp settings, but no luck so far. I use yafray, is that why?

Years ago during a project I came to the conclusion that the only solution is to render to a xml file and edit shadow=off in each object you want to do it.