How do I adjust normal map "intensity" ?

I have a very basic material with diffuse color and normal map plugged into it.

For whatever reason normal map seems to be too intense, making details on the surface really coarse. How can I adjust normal map’s “intensity” to make surface detail look less pronounced?

Thanks

P.S. 2.77 and Cycles. Same normal map looks fine in UE4.

Ermmm

/uploads/default/original/4X/4/b/9/4b9f54beb9b58239405fc67d3319b10a4d10594c.pngstc=1

Attachments


Oh, cool, thanks! I was just plugging Image Map straight into Normal Map socket on the Diffuse Shader :confused:

Yeah, don’t do that. :slight_smile: Cycles expects normals in world(?) space for that input. Use the normal map node to convert a tangent-space normal map into Cycles’ normal format, that’s what it’s there for.

I actually tried that node and it looks like sh#t now :confused:

Will try baking object space normal map and see if that works better.

Did you remember to set your image node to “non color data” to disable gamma correction?

1 Like

You may also need to turn the intensity down ridiculously low on a simple shader. 0.1, or even 0.01. Example. This is with intensity of 1, 0.1, and 0.03. The latter is closer to what I aimed for.

Attachments




roken, why do your node connectors look so wide?

Was wondering that myself, I know you can alter the curving, but wasn’t aware the thickness could be adjusted.

Also, since these maps are composed of “image-like” data, you can use Curve nodes and such to adjust them … basically re-mapping the range of numeric values within the map to anything you need it to become. You can apply this same technique to any sort of map.

Dunno, it’s just the theme.