How do I assign material to emptys?


(morpheus) #1

ok dumb question I know! I’m trying to animate an object without getting the sliding texture effect - I know I have to use an empty as a control object but I cant seem to assign the texture to it… Im sure this is really simple but any help would be greatly appreciated!
Thanks! :smiley:


(ilac) #2

HI,

  1. You cannot assign a material to an empty! What you can do is use the empty (or any other object) as the texture mapping mode - which seems to be what you want.

In the material window on the right hand side (which handles how a texture applies to the current material), you will see various buttons such as:

orco, global, refl, object, uv, sticky etc.

If your texture is sliding when you object is moving you probably have the Global setting selected. If you want to use the empty as a control, then you need to select the Object mode and put the name of the Empty in the space provided next to the object button.

Which mode you use obviously depends on how you want the texture to behave!

Hope I’ve solved your problem!

:smiley:


(morpheus) #3

Yep thats sorted it out! Thanks! :smiley: