How do I bridge these two loops? The original way to do so wont work


As you can see, I have both loops selected (I pressed shift alt to select them both
I’ve already tried “Edge” > “Bridge Edge Loops”, and it tells me to ‘select 2 edge loops’
I’ve even combined them into 1 in object mode, to help with the bridging process.
Does someone know what I might be doing wrong? Or if I’m missing something?

1 Like

Any doubles? Make sure there are no doubles by merging by distance with everything selected.

First: You don´t have to open every time a new topic for the same problem.

By combining you mean that you have joined the 2 meshes to 1? In edit mode, make sure you have no double vertices in the same location. Select all with “A”, press “M” → Merge by distance, to remove double vertices. Do you have LoopTools activated in the preferences? If not, you should do it (helps a lot with loops). Select the first edge-loop, then shift-select the second edge-loop. With LoopTools activated: right-click → LoopTools → Bridge.

Just a beginner here, but I struggled with the same problem - until I realized it only worked (in my situation) when the two meshes were part of the same object? So CTL-J join the two first.

(Object mode, Select the child object first then parent, CTL-J, Now the two separate pieces are actually one object.

Back to Edit mode, select the two loops, CTL-E, select Bridge Edge Loops and ta-da!)

ETA: which makes sense - after all, once they are bridged, they cannot be two objects (or else, which object do the bridge faces belong to?). Also, better to have you specifically join the objects instead of that being a surprise side effect of a simple modelling “Bridge” command.

Oh yes, you can still separate the mesh in two or more objects after bridging.
Select the part of the mesh you want to separate, P, Separate by selection.

Yes, very true.

My last point was - you don’t want Blender making these decisions automatically for you. Suddenly it’s one object, then again maybe it’s two, then who do the bridged faces belong to? better that the modeller explicitly determine this.

But thank you, I learned something new today! It never occurred to me you could do what you suggested, so I tried it. Intersting, thanks!I took a cube, Ctl-R to subdivide 3 ways it so it looked like a Rubik’s cube. I did as you suggest, select a portion (turn on xray to see all vertices). Use P to separate the selection. By manipulating only one selection, it is apparent that the dividing loop between the two was actually duplicated by P-Selection. If (Edit Mode for only one object) I grab a vertex on the boundary for one object and move it, there’s another vertex in the same place belonging to the other object that does not move - so the boundary was duplicated.

Obvious, since faces have to be deleted adjacent to the boundary if there are no vertices or edges along the boudary loop for one object.

Also note if I separate the two half-cubes, I can see the P process did not create a face to fill the interface between them.

Again, I suspect very simply, Blender would like you to decide how this sort of thing happens, what faces and edges and vertices belong where, rather than making assumptions.

Its like cutting a sheet of paper. The boundary or edge loop splits.
Cutting one sheet into two half’s. Its logically that one boundary belong to one half, and the other to the other half.