How do I change an object't origin?

I joined two objects together; now the origin/median/manipulator off to the right, about somewhere about between what used to be separate objects.

I’m new to the site but I think you posted this in the wrong forum.Try posting in the modeling forum instead.

Go to the tools shelf, pick origin, and select origin to geometry. Play with the other options as well.

Also, a nice shortcut for placing the origin at geometry is Ctrl+Shift+Alt+C > Origin to Geometry.