How do I change the render background without effecting the model?

I’m a Blender rookie, and I’ve read many tutorials.

I’m taking a 3d model, animating it into an AVI, then taking it into After Effects. Because the background is black, the Chroma Key is screwing with my models.

I’ve read lots of solutions, but they keep sending me back to the Blender Docs, which is different version then I have, and it has pictures and options I can’t find.

I want to change the background to green, WITHOUT changing the color of my models. Where specifically do I need to go to achieve this? When I load up a green picture as a texture, then click “render image” to test it, no matter what I select, the background goes back to black.

Thank you for your time.

Try setting Green screen material with Shading > check on Shadeless.

Where is this? I’ve clicked on everything haha

Here’s the shadeless button:

Also, in the world settings, you can change the colour of the background to any colour:


Huh… that’s the strangest thing. I don’t have the “red ball” button. I assume that’s why I can’t find it. It should be next to all the others (world, render, etc) right? Maybe I accidentally removed it. Where do I find it/readd it?

I REALLY appreciate your help. I was ready to pull out my hair haha

what blender are you using?

According to the Splash Screen, 2.59.00

this? then select the camera, click the black color and change to green?

I have that button. But when I change horizon, all it does it make my model have a green haze, then background is still black when I render an image.

is it possible for you to give me a screen shot or the .blend file? so i can see what it is?

What specifically would you like a screenshot of? Or yes, I could just send the file. I don’t want to inconvenience you, though.

the world settings, the material settings on the object, things like that. or the blender file it self would help.

How can I send it to you? Email?

when you reply, look to the corner and click, “Go Advanced”. then click the paperclip with the paper on it, and upload the .blend file.

Why don’t you just ditch the background and render the animation out in PNGs with an alpha channel? Saves all the trouble of keying and such.

In regards to the haze affect, do you have environment lighting on?

It won’t let me upload the file. Just not my night.

I’ll just keep trying different combinations of clicking until I figure it out haha thank you for trying, though!

I tried that, too. The background is still black. I know I’m doing something silly incorrectly. I’ll figure it out eventually.

Try for uploading the .blend.

The background will be black if there is an alpha channel…blender doesn’t display the alpha channel by default. If you take it into aftereffects, does the background still remain black?

stupid question, but do you have a lamp?

I assume you mean in the scene :stuck_out_tongue:

Yes, I have several.