How do I change the view "wireframe" to a "smoother" look (not subdivision surface).

How do I change the view “wireframe” to a “smoother” look (not subdivision surface, at least I don’t think).

I don’t even know the proper terminology for this one (thus the title may not make sense, and thus I may not have been able to find the answer via the search function). I’m trying to follow some youtube 3D beginner modeling tutorial and came across this one.

At the 12:44 mark, he switches to default view and his character turns completely smooth. I tried the subdivision surface modifier but it simply added too many lines to the model, and that doesn’t help me keep up with the tutorial. Plus, it had these blotches all over the model.

I even tried looking through the comment section and this same concern comes up a couple times with no one able to answer.

Blender Character Modeling 1 of 10https://www.youtube.com/watch?v=0QT1GNMevfc

How do I get it to look like this?
http://i128.photobucket.com/albums/p175/strawberrysundayshortcake/Blender/Blender%20Surface%201.jpg

I’m trying to follow that tutorial, and my model looks like this, which is exactly what the tutorial had me do, but then the youtube author went into default mode (I’m also in default mode" but my model doesn’t look like his with respect to the smoothness. http://i128.photobucket.com/albums/p175/strawberrysundayshortcake/Blender/Blender%20Surface%203.jpg

This is what happened when I added Subdivision surface modifier - too many blotches over the model. I don’t think the youtube guy went into the subdivision modifier option; or maybe he did, I don’t know. At least he didn’t mention it in the video.
http://i128.photobucket.com/albums/p175/strawberrysundayshortcake/Blender/Blender%20Surface%204.jpg

Change from flat shaded to smooth shaded (button in toolshelf in object mode)

Also check your face normals are pointing outwards. Recalculate selected face normals with Ctrl+N

Cool. Thanks. Much appreciative. Worked out nicely.

Also great tip on the Ctrl+N. Now everything looks normal.

P.S. Also don’t know how long this response post is going to show up considering I’m a newbie with only 3 posts at the moment.

http://i128.photobucket.com/albums/p175/strawberrysundayshortcake/Blender/Blender%20Surface%207.jpg

http://i128.photobucket.com/albums/p175/strawberrysundayshortcake/Blender/Blender%20Surface%20Ctrl%20N.jpg