How do I clean this up?

so as seen in the screenshot, there is these weird lines and curves, and defects in what is supposed to be a flat face, I’m fairly new to blender, and have no idea how to get rid of those, and no I dont have money for any fancy addon so please dont point me to one

First make sure all the faces, vertices that are supposed to be on the same flat surface are surely flat- to check this u can select all the faces and scale in the same axis its facing.

2nd thing is that u can and a Split edge modifier.

3rd… u can always do a normal recalculation (shift+N or Ctrl+N)

The model structure has many concave n-gons, n-gons being faces with more than 4 sides, and there’s not enough geometry for automatic triangulation to operate cleanly. Probably a result of boolean operations.

The limited view to the setup doesn’t tell if the shading is managed appropriately. Use auto smooth instead of edge split modifiers, unless you know you actually need to split edges within the modifier stack.

Add cuts to give Blender more options for triangulation, and could also use mesh menu -> clean up -> split concave faces after face selection.

Please keep in mind that no face must be dented inwards and some of yours look downright like the Gulf of Mexico. I’m afraid there’s no other way than subdividing everything by hand; the artifacts will disappear after that.

Have a look at the link, the answers there explain it in more detail

If you join some vertices you can reduce this effect:

select two vertices on either side of your face at all the narrow spots and join them (press j)
This will reduce the concavity of the n-gon and make it a little easier to shade.