How do I embed image into Blender

I tried to embed image by pressing N and using the background image box to embed. I followed the steps and ‘embeded’ it - but it doesn’t seem to work. Why would that be? Thanks in advance.

You need to be in orthographic view mode and in the view you have set in the background image settings) for the background image to show. Toggle between orthographic and perspective with numpad 5
http://cgcookie.com/blender/2010/03/15/using-multiple-background-images-in-2-5/

I went in orthographic mode and followed the same steps as I outlined in the previous post. I couldn’t see the image until I changed the view setting for the image, yet then I could see the image in different view settings (ie. top, front, left, .etc).

Due to me being over my quota, the video would take far to long to load, thus, I can’t watch it :frowning:

Thanks thus far, you are being an excellent help !!!