How do I get emission lights to reflect in shiny surfaces?

I am trying to recreate a photo in 3D in Blender, but the Christmas lights don’t reflect in the shiny ornament like they should. Also, I would like the lights to be brighter without emitting more light. The light coming from my bulb looks like a spotlight, not how it should look. How do I control the emission light?

Here’s the photo:

Here’s my render:

I tried using the glow node in the compositor, but it’s not exactly what I want. Are there more options for this with greater control?

I would like glints of light something like this:

Show your material nodes for the light and the ornament metal.

Here’s the materials:

For testing make the glass material completely transparent. make the emission material strength of 50. and make the metal bulb a glossy node, 0 roughness, color red. something isn’t right, maybe bounces, or visibility, if you can share the blend do that.

On first look, my initial guess would be that it has something to do with using Eevee. In the Limitations section of the manual under Eevee, it says something about not performing “specular to diffuse” or “specular to specular” bounces. I’m not sure if this is that issue, but a strength of 5,000,000 also seems a bit extreme. What happens if you render in Cycles?

I am using Cycles.

Photox, I did what you said to test it out. 50 emission barely glowed at all.
I accidentally duplicated just a filament outside of the bulb. That does reflect. Inside the bulb, not at all. So, should I just parent a light inside the bulb? The filament just isn’t doing it. When I turn it up high enough to really glow, the light emitted from it blasts everything out.
Or, do you think my settings just aren’t right?

Emission is set to 5000000 here.

Thanks!

This is with a point light inside the bulb. Why is the reflection a huge circle?
That won’t do at all.

What is it about the glass of the bulb that’s blocking reflection of the filament?
Can I somehow turn off something to improve that? I turned off shadows.

I lowered the HDRI level, so it’s darker in the room. I turned down the filament emission to 500.

The setting for your material needs some adjustments: the color space for the textures used for metallic, roughness, and displacement need to be Non-color.

Other than that, with a basic setup, I can already see the lights reflected onto the sphere. Increasing the clearcoat improves it further - not sure whether it’s physically correct or not but I don’t pay attention to that anyway :wink:

as for the emitter material, I’m using an emission strength of 10.
With some basic contrast-glow-glint you can increase the effect in post (any compositor will do)

1 Like

Thanks. I changed those material textures to non color. Didn’t change much, but I know that’s the correct way of doing it.

If I set my emission material to 10%, it wouldn’t show up at all. 50% was barely lit up. I wonder what the difference is. And yours are reflecting just fine, even inside the glass bulbs. What’s different?

I looked up a lens flare add-on. I’ll try that. That’s what I used to do in Lightwave anyway. Maybe that’s what I really need. I want more control over how bright it is. I notice you are using something called Xglow1. Is that a third party thing?

Thanks!

Another odd anomaly that I’ve been having with this ornament is that when I select it and push period on the numpad, it moves the view away from the bulb. It’s still pointed at it, but it’s farther away. When I go into Edit mode and do the same, it frames it as it should. I’ve checked that the origin point is in the center of the ball. I even moved the mesh data into a new object. No change. Any ideas?

I downloaded the basic ornament from a website. I made some changes to it, and remade the UV map, and added the textures. I should have started from scratch since it’s such a simple object.

Thanks!

Instead of a point light inside the bulb, model a small filament and give it an emission material with strength ~5 - 50

That’s what I was doing originally. You can see the filament in the above photos. I duplicated the filament and dragged it outside the bulb. It’s there to the left of the top bulb. Outside of the glass, it reflects just fine, but not very bright.

I noticed that the point light I added had an emission material on it. Are all the lights in Blender just objects with an emission material?

Thanks.

Any chance you could share the scene?

As for the xglow that’s from Fusion but you can achieve a similar result with Blender’s compositing tools.

This might be unrelated to everything apart from why you need your emission values dialled up so high, but what size are your Christmas ornaments?

set all clamping values to 0

share the blend

Alright, here’s the file: https://www.dropbox.com/sh/2y1vwdj2z8lu10g/AAAavhsfPFHZLjcgquOvjz6oa?dl=0

I have tried to make everything actual size. I modeled the X-mas lights actual size, and scaled down the ornament to be closer to reality. It was 200 mm originally. I have been wondering if scale it a problem here. I see people on YouTube videos modeling by “Blender units”, which is like, a meter, if I’m remembering correctly. I like to model things actual size, unless I’m dealing with a bacteria or a planet or something extreme.

Thanks!

I’m taking a look. At first glance, I’m noticing a couple of things:

  1. The material for the Christmas ball has a principle BSDF and a Glossy, but only the glossy is being used. Maybe you wanted to mix the two shaders?
  2. The geometry with the emitting material is too thin. Just increase the thickness and you’re close.

With the current thickness

With more thickness

I have the feeling the scale might be off, but I didn’t check all the settings in your scene.

Thanks! That’s helpful.

The glossy node is just an experiment. The principled BSDF node is the original. It has the color texture with it.

The bottom right lightbulb also has an instance of that filament. I wonder why it isn’t showing through the glass like the top one.

Also, did you try selecting the ornament and doing “frame to selected”?

Thanks again.

You have an extra vertex, just delete it:

As for the instance, is it possible that you have instanced only the light bulb object and not the filament?
Since they’re nested you have to make sure you select both or else only one will be instanced.

I suspected something like this, and I tried to delete everything outside of the ball, but I guess I wasn’t in vertex select mode. Thanks!

Yes, I noticed that duplicating the light bulb didn’t include the stuff inside. I was thinking everything parented to it would be copied, but no. So, I have to select everything, then instance?
Alright, but I did notice that, and I duplicated a filament and moved it into that bulb, so it does have one. You can see it here, with the emission set at 500000.

Another noob question. When I duplicated the filament, it stays where it is, but then I wanted to move it to the other bulb. I thought I could just change parents, but no, that doesn’t work. How do I change parents and have the thing snap to where it should be?

Thanks again!