How do I get rid of every single header (and I mean EVERY single header)

Hey guys,

I am doing a light mapping project and am using Blender for my meshwarping. Now for the most part, it’s been okay (although Blender feels counter intuitive from every single other CG app I have ever used in the history of ever. Everything seems to be as user un-friendly as humanly possible-- but I can’t complain since it’s free, I guess.)

I have managed to hide most of the windows/headers, but I can’t get rid of the top most one. No matter what I do, even if I pull it down to expose what appears to be the console, and then hide the header, when I drag it back, the stupid window does not disappear, it just sits there mocking me with it’s user-unfriendliness.

Please guys, I am to my wits end, and I have desperately tried and googled everything to do with those headers, and so far nothing. (It seems blender 2.4 had an option to just right click and hide the headers, according to Google anyway-- but this feature was removed for 2.6??? So infuriating, why would the developers scrap that one tiny little feature???)

I know it’s probably not Blender that’s the problem, but rather my lack of knowledge about it, so please Blender guru’s you are my only hope.

(It seems blender 2.4 had an option to just right click and hide the headers, according to Google anyway-- but this feature was removed for 2.6??? So infuriating, why would the developers scrap that one tiny little feature???)
2.49 and 2.6 have the same functionality in removing/collapsing headers

Why not just remove the window altogether by joining with adjacent windows (RMB on common window borders)

I have tried that multiple times, and it seems to work for every other window, but just not the top most toolbar/header. I right click on the border, select Join, and it does not let me join it to any other window. Like I said, I can pull it down to reveal the console, then I can access the top border of the tool bar and hide it by draggin down, but it’s pointless because then I just have a tiny bit of console at the top that I can’t for the life of me get rid of.

because the headers are so intrusive, right? i mean with all the screen real estate they take up the devs should just totally redesign blender and remove them entirely. I mean, what are they even for, it is not like they have any useful purpose, like if they held some easily accessible tools or handy functions relevant to the screen they were heading there would be some point, but they are there just to take up space, for sure. I propose we all get together and discuss this UI anomaly, and start a campaign to ensure the blender foundation fix it

I realize that you are being facetious, but for this particular project, I require the 3D view to be in full view and be as close to 1:1 to the screen as possible. I have managed to achieve that 99% of the way through, and the top header is the last thing that is stopping me. I also realize that this is not a concern for 99.99999% of the Blender users, but if I am able to hide every single other window and header, why not the top one?

I can’t see my replies yet, because a mod hasn’t approved them, but I just wanted to add an image reference to what I was talking about.


This was taken directly from the wiki for Blender 2.49— when I right click the same areas, the No Header option is completely missing, so this is why I believe the functionality (or at the very least the functionality of the UI) has changed since 2.49. Once again though, due to my lack of experience I am most certainly probably missing something. But my fervent Google searches have led me to believe that this is in fact the case. Please correct me if I am wrong, I know that I am most likely just missing something, or trying to use it in the wrong way.

I have managed to find an adequate solution, with some messing around, I was finally able to get the Join window option to work. I thank you for your time and patience.

yah I’m messing with you, i don’t know how you have managed to get rid of the headers already, as you say the function has been removed since 2.4. the only real suggestion i can make is to use the full screen mode, (toggle fullscreen, from the view menu in the header bar ironically!) or ctrl up arrow, though it doesn’t quite give you the full screen as you still have headers. at least you figured out how to join the windows, one single open window gives you the most screen real estate as you dont have the menu header ( file add etc) that you get in full screen mode.

Shift+Space ?

Hi yrokhlin,

Here is what works for me:

Choose 3D view full from the 1st pull-down in the header:

Then hide this “info” header like that:

You’re left with an almost empty window:

Then go to full-screen (Alt-F11).

Like that you can use every single pixel of your 640x480 screen :wink: