How do I get rid of these edges in render

Hello everyone.
Hopefully someone here can help me with this. I’m sure the answer is simple, but I cant figure it out.

I am trying to get rid of these edges in the render. The quad faces seem planar in the 3d view before rendering. If they are not I don’t know how to detect them before rendering. I’m assuming that’s what the problem is. If not can someone tell me what I’m doing wrong. :spin:

If the faces are non planar apply smooth shading and use an edge split modifier to control where you want sharp edges

Wow. Thank you for the quick reply. I did what you said and it worked. By the way is there a way to detect non planar faces?

Thank You, again.

You can enable the ‘3D Print Toolbox’ addon and check for distorted faces with an angle set to zero degrees

or in the Properties panel (N) under the Mesh Analysis (edit mode) select distortion and change the angles