How do I get rid of these strange black patterns?

Im getting strange solid black spots with straight edges in my text and Im not sure how to get rid of them?

They are not being caused by my environment map. Changing or rotating the env map in “mapping” coordinates doesnt change where the spots are or their size or shape. I’ve changed max bounces to 1024 and various other settings.

Text is set to glossy with “0.00” roughness. If I change it to .01 or .1 then as it becomes rougher the black spots become more gradient, but that destroys the mirror like effect I want. So any ideas how to get rid of these ugly black areas?

Im on a 2013 MacPro, GTX 1080 Ti, Sierra 10.12.16
64GB RAM


Without seeing the .blend file this is a guessing game…
I’d say you’re using smooth shading on an object with both smooth and flat areas. If this object has been converted to mesh, activate AutoSmooth. If this it is still a text, add an Edge Split modifier to it.

And BTW, you might want to change the font. Using the default built-in font is just lazy…:stuck_out_tongue:

Genius! It is still text and I did add an edge split and it DID work! Thanks a ton! And regarding the font, guilty as charged. Ive got a series of about 20 3D text shots like this one and I did start using a different font, but forgot to use it on the other shots – and actually, this one works better for what we need anyhow so its staying :slight_smile:

After working with these some more, I’ve found that while the edge split does eliminate the black areas, it also significantly reduces reflectivity of the text.

I don’t see how it could. I’d rather guess the reflections now are realistic, while they also suffered from smoothing errors before. That wrong smoothing might very well have turned the flat areas into rounded ones, giving them exaggerated reflections.

I think they look like shadows judging by what you’ve shown us. Try increasing the size of your light source or disable shadows

Thanks for the suggestion, but I have tried them both already. Definitely not shadows. Moving lights, changing light intensity and even rotating my environment map which is lighting the text, rarely changes the black areas.