How do I get Spec Maps to Work in GLSL Shading Mode?

For the life of me I cant figure this out. My specular textures aren’t showing up when I’m in GlSL Shading Mode.

First my settings:

  • I’m using Blender 2.71 and 2.68 Alpha respectively
  • It’s set to the Blender Internal rendering engine
  • I have it set to GLSL shading and I’m in the textured view port mode.
  • I have lighting
  • My mesh is uv unwrapped and I have textures for the color, the specular intensity, and the specular hardness currently.
  • In my materials options I’ve turned down the specular intensity to zero and my specular hardness is set to 50.

For whatever reason my spec maps aren’t showing up when I’m in GLSL shading mode. I can render out an image and my spec maps are working just fine, but I cant see them in real time.

Does anyone know why this is? Is this a bug, because I never had this problem before in earlier versions of Blender. Is there some setting that I’ve overlooked?

Please, if you know what’s causing the issue, if you’ve experienced this yourself, please let me know what I can do to resolve this. Thanks!

I figured it out. I was using Hemi lights and spec maps apparently don’t work with Hemi lighting. I switched over to sun lamps and it worked fine.