How do I hide edges of an object?

Hi all,

(not sure if this is in the correct thread)

I was trying to model some stuff for my game when I accidentally enabled an option that shows the edges for some parts of my model. So how do I turn that off?
I tried disabeling draw all edges in the properties window, but that doesn’t help.

Thanks already.


Right above draw all edge is wire unchecked?

EDIT: By default blender doesn’t show edges between planar face. Those are the only edges that draw all edges effects. The wire checkbox shuts off all edge display.