How do I install OpenXR?

Ive been trying to figure out how to get VR working in Blender 2.83.2. In the details on this page https://docs.blender.org/manual/en/2.83/getting_started/configuration/hardware.html#getting-started it does not tell me much. Ive followed the instructions given but when I go into Blender I get an error message: “Failed to Query OpenXR runtime. Do you have an active runtime set up?” So I clearly do not have OpenXR installed for my Rift S. Information on it seems to be limited. It does direct me to Github, but I can only find the source code there not something I can execute. I have no idea how to use the source code.
So where do I get the runtime and how do I install it?

Do you have Steam installed? It worked for me without any additional software, I only have the Oculus software and Steam VR installed.

Hm, the manual even says that the Oculus software should be enough. Are you running Blender using the blender_oculus file?

Thanks for the response. Yes I have both the oculus and steamvr installed, and yes I was trying to run it from blender_oculus file. Only thing can think of at this point is that I need steam switched on as well as the oculus software.

Finally solved the issue. Instead of just clicking and going when using the blender_oculus file, I decided to read all the text in the command window. It then dawned on me that it was pointing to a file location that did not exist. I don’t install software to default locations if I can help it. So I adjusted the .json file with the correct location and all now works.

Brother! Do you mind telling us mere mortals just how to do that?

Whats the Blender_oculus file? What .json file are we talking about? And what do we want it to point to? :pray: